Portal Home > Knowledgebase > VMware Knowledge Base > VMware Tools status shows as not running after running VMware Consolidated Backup

VMware Tools status shows as not running after running VMware Consolidated Backup

Symptoms

During the normal VMware Consolidated Backup (VCB) operation, the VMware Tools status changes from OK to Not Running for some time during the initial snapshot operation, but it returns to OK after the VCB operation completes.
 
However, on hosts installed with the patch bundle ESX350-200901401-SG, the VMware Tools status on the virtual machines may stay as Not Running even after the VCB operation completes.

Resolution

This issue is resolved in ESX 3.5 Update 4. Upgrade to ESX 3.5 Update 4 to permanently resolve the issue.
 
For prior releases, see the workarounds that follow.

Perform one of the following options as a workaround:

  1. Restart the mgmt-vmware service immediately after the backup job is done. This changes the Tools status to OK. You can write a cron job to do it periodically.

    OR

  2. Log in and log out, or log out if you are already logged in, from the virtual machine. This changes the Tools status to OK if it was showing as Not running.

    OR

  3. Use VCBMounter to look for virtual machine name or UUID rather than virtual machine IP. Virtual machine IP only works when the status of tools is OK, but virtual machine name and UUID works even if the Tools status shows asNot running.

  4. Based on VMware KB 1008709

Also Read

Language: