Portal Home > Knowledgebase > VMware Knowledge Base > ESX Server 3.5, Patch ESX350-200802403-BG: Improved Statistics Collection for Support Scripts, Fix for Patch Issue Seen After Upgrading from ESX Server 2.5.x to 3.5.0

ESX Server 3.5, Patch ESX350-200802403-BG: Improved Statistics Collection for Support Scripts, Fix for Patch Issue Seen After Upgrading from ESX Server 2.5.x to 3.5.0

Details

Release Date: 3/10/2008
Document Last Updated: 3/10/2008

 

Download Size: 312 KB
Download Filename: 
ESX350-200802403-BG.zip
md5sum: 
92146fe2c1a317e56905534f3a3cd9fe



Product VersionsESX Server 3.5
Patch ClassificationGeneral
SupersedesN/A
DependenciesN/A
Virtual Machine Migration or Reboot RequiredNo
ESX Server Host Reboot RequiredNo
PRs Fixed220762, 245751
Affected HardwareN/A
Affected SoftwareN/A
RPMs IncludedVMware-esx-scripts
Related CVE numbersN/A

Summary

This patch fixes the following issues:
  1. The options -s and -S do not work correctly in the vm-support script. 

  2. After upgrading from ESX Server 2.5.x to 3.5 using tarball esx-3.5.0-64607-upgrade.tar.gz, a subsequent patch upgrade fails. This problem occurs because of a missing descriptor file in the patch database directory. This issue does not appear on systems upgraded to ESX Server 3.5 from ESX Server 2.5.x using ISO CD or on a fresh installation of ESX Server 3.5.

Solution

Symptoms

  1. When vm-support is run with the -s or -S option, data cannot be collected properly because the script invokes the vshutility from the wrong path.

  2. The patch installation fails with an error message similar to the following:

    ERROR: [ESX350-200802303-SG] requires ['3.5.0-6460*'] but these bundles cannot be found. Please make sure they are in the depot and specified in the bundle list.

Deployment Considerations

None

Based on VMware KB 1003446


Also Read

Language: