Portal Home > Knowledgebase > VMware Knowledge Base > Upgrading to vCenter Server 4.0 fails with the error: Setup failed with an unknown error during DSN validation

Upgrading to vCenter Server 4.0 fails with the error: Setup failed with an unknown error during DSN validation

Symptoms

  • Upgrading from vCenter Server (VirtualCenter) 2.5.x to vCenter Server 4.0 fails
  • You cannot upgrade from vCenter Server 2.5.x to vCenter Server 4.0
  • After entering credentials for your DSN, you see the error:

    Setup failed with an unknown error during DSN validation

Resolution

This issue can occur if you are using an incompatible ODBC client driver or if the current driver is corrupt. 
 
To ensure you are using the correct ODBC driver, see the vSphere Upgrade Guide.
 
If the driver version is correct, then it is likely corrupted and needs to be reloaded. Contact your vendor for more information.

based on VMware KB 1022249

Also Read

Language: